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UP A N D RU N N I N G
W I T H FE T C H 1 . 5 WE L C O M E TO EX T E N S I S FE T C H!

WHAT IS EXTENSIS FETCH™?
Fetch is an electronic media cataloging tool that gives you quick, easy, and efficient ways to organize, browse,
manage, retrieve, and use files containing digital data. 

Fetch catalogs all types of digital files and images, regardless of the file format, file location, or the application
used to create the file. Cataloged files can be viewed as thumbnails or by list, and information about the image
file, such as size, type, creation date, location, and other data are available at the click of a button. Keywords
and other search criteria help you quickly locate, access, and reuse your digital files. And handy drag and drop
functions give you easy ways to transfer, copy, or place cataloged images.

HOW CAN FETCH HELP ME?
Fetch makes quick work of finding and retrieving images. 

Use Fetch to keep visual catalogs of: 
• All the art and photographs used in a newsletter, brochure, manual, or presentation.
• Artwork, pictures, scans, movies, sounds, and even 3D images that you may want to use repeatedly in

different projects. 
• Miscellaneous pieces of clip art for quick and convenient reference and use.

Or use catalogs to visually distinguish similar images, such as different sizes, colors, or content of a masthead or
logo, or where filenames alone are not enough to describe images. And it’s really simple to do—simply drag and
drop your files onto the Fetch icon or into open Fetch windows to create, add to, and update catalogs. You can
even drag and drop items right from the catalog into documents that you create in other programs that support
this feature, such as QuarkXPress®, PageMaker® 6.5, and ClarisWorks®. And because Fetch catalogs capture
only a thumbnail image of each cataloged file and not the file itself (keeping instead a “link” to the file’s loca-
tion), cataloging images with Fetch takes much less storage space than copying images into a scrapbook.

HOW CAN THIS QUICK START GUIDE HELP ME?
If you’re new to Fetch, you can use this guide as a quick way to get “up and running.” But even if you’re an old
hand at creating and using Fetch catalogs, you may find some exciting new features here. When you’ve finished
with this guide, you’ll know enough about Fetch to create and use simple catalogs, and you’ll be aware of some
of the more commonly used features. To learn more about Fetch and the many options and features available,
refer to your Extensis Fetch User Manual and to the ReadMe files in your Fetch application folder.

Extensis, Extensis Fetch, QX - Dr a g & Dro p, and Cy b e r Vi ewer are trademarks of Extensis Corporation. All other trademarks and re g i s t e red trademarks are the pro p e rty of their re s p e c t i ve ow n e r s .

BROWSING CATALOG ITEMS IN THUMBNAIL VIEW

BROWSING CATALOG ITEMS IN TEXT LIST VIEW
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THE SAMPLE CATALOG
A Sample Catalog, located on the Extensis CD inside the Fetch 1.5 folder, includes samples of the many types
images that can be cataloged and viewed (including sounds, movies, and 3D images) with Fetch. We suggest yo u
use this sample catalog to experiment with the different features highlighted in this guide. If you do not have
access to the Sample Catalog, or wish to create your own catalog, refer to page 8 “Creating A New Catalog.”

OPENING A CATALOG
To open Fetch, simply double-click on the catalog icon you wish to view, drag a catalog over the Fetch icon, or
double-click the Fetch application icon. Note that when you double-click the Fetch icon, Fetch opens whatever
catalog you have indicated as the “default” catalog. If no default catalog is indicated, Fetch will allow you to
either create a new catalog or to locate a catalog to open.

DISPLAYING ALL CATALOG ITEMS
After Fetch has opened your catalog, and before any images are displayed, Fetch presents the “Find” window.
The Find window allows you to search for and display only the items you’re interested in viewing at the time,
rather than all the images in the catalog. If you wish to view all the images, simply click “Find All,” or press the
Return or Enter key. Note: Find All is available when the search word box is blank, or when search criteria is dese -
lected. To make Find All available: delete the search word; click “Clear;” click the “x” box so that the box is empty;
choose “Find All” from the Search menu; or use the keyboard shortcut CMD+’ (apostrophe).

Fetch then finds all the items in your catalog and displays them in the Gallery window. Items will be displayed
in either Thumbnail view or List view, whichever view was being displayed when the catalog was last closed. 

On the example, notice the name displayed at the top-center of the window : Sample Catalog ◆ Ga l l e ry. This indicates
that the displayed items are from the catalog named “Sample Catalog” and that we’re viewing items in the Ga l l e ry
w i n d ow. The Ga l l e ry window is one of two primary windows. The other primary window is the Find window.

In the upper-right corner of the Gallery window, Fetch indicates which view is being displayed, in this case
“Thumbnail View.” To change the display to List View, select “Text List” from the View menu, or enter
CMD+L. To change back to Thumbnail View, select “Thumbnails” from the View menu, or enter CMD+T.

Notice the upper-left corner of the Gallery window—Fetch indicates how many items are currently being dis-
played. In our example, we searched for all items in our Sample Catalog, so the window accurately reflects the
total number of items in our catalog: 215.

Use the scroll bars in the Ga l l e ry window to move up and down the list of displayed items. You can also re s i ze the
w i n d ow as you pre f e r. To access the Find window at any time, select “Fi n d” from the Se a rch menu, or enter CMD+F.
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DISPLAYING SELECTED CATALOG ITEMS
Use the Find window to search for and select particular items of interest. For example, say we’re interested in
finding some pictures for a newsletter we’re writing, and that our newsletter focuses on eating and nutrition. We
know that some of the items in our catalog relate to food, and that when our catalog was created these items
were given appropriate “keywords” so we could find them easily. One of the keywords we created was “food.”

Using the Find window, we select the appropriate search criteria. In this case we select: Find items whose
Keyword ▼ does ▼ match ▼ then enter the word food in the search-word box and click  “Find.” Note: The
arrow (▼) lets you know that you can “click and hold for more choices.” You can access the Find window at any
time with the keyboard shortcut CMD+F, or by selecting “Find” from the Search menu.

When the search for all items with the keyword “food” is complete, Fetch displays them in the Gallery window
in whatever view was last used (in this case, Thumbnail View). In our example, Fetch indicates (in the upper left
corner of the window) that 11 items with the keyword “food” were found.

If our search resulted in too many items, or we didn’t find the item(s) we we re looking for, we could generate a
n ew search. We could try using a different keyword, or use the dro p - d own menus to change search criteria options,
or we could click “Mo re Choices” to add search criteria and narrow the search. T h e re are numerous search options
a vailable, including searching by Filename, using AND/OR, using Do e s / Does Not match, etc. For a more detailed
description of the search criteria and choices available, refer to your Extensis Fetch User Ma n u a l .

PREVIEWING CATALOG ITEMS
Once you’ve located an item of interest, there are a number of things you can do with it, including looking at a
larger view of it. This larger view is called a “Preview.” To Preview an item, simply double-click its thumbnail.

In our example, we scrolled down the list of items being displayed and found a picture of grapes. We double-
clicked in the image area of the thumbnail and Fetch displayed our picture in a Preview window. Note: Double-
clicking in the text area under the image displays a more detailed screen of information about the item—for more
information refer to the next section “Viewing Item Information.”

Notice the information that is displayed at the top of our Preview window. At the very top, the filename of the
displayed image is shown, in this case “Grapes.low.tiff.” Beneath the filename Fetch displays information about
the image. In this case, Fetch indicates that the image is actually 4.75” wide and 4.47” tall, and that we are
viewing the image at 100%  of actual size (in other words, actual size). Fetch also displays the type of image
being viewed. In this case, our image is a TIFF file.

Notice the special arrow (     ) in the upper-left corner of our Pre v i ew window. When Fetch displays this arrow
it indicates that you can “double-click here to display additional information.”
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VIEWING ITEM INFORMATION
Double-clicking in the text area below a thumbnail in the Gallery window Thumbnail View opens the item’s
“Info” window. This window displays detailed information about the image, including its filename, type,
size, creation date, modification date, pathname, keywords, and description. 

In our example, the item description indicates that this is a stock art image from Image Club Graphics and
that it is available in high resolution TIFF format. The info window also shows all keywords assigned to the
item. The number beside each keyword indicates how many items in the catalog have been assigned that
same keyword. Note: Double-clicking on any keyword in the keyword list initiates a search for all items with that
keyword. When the search is complete, the found items are displayed in the Gallery window.

You can view even more information about the item, such as the location of the file (full pathname), and the item’s
resolution and bit-depth, by clicking the little flipped-up-page area of the File Info and Fetch Info windows.

You can also access the item Info window by: clicking the      arrow in the title bar of the item Preview win-
dow; by double-clicking the item’s filename in Gallery Text List View (described below); or by selecting the
item in any view and choosing “Get Info” from the File menu.

DISPLAYING AN ITEM IN TEXT LIST VIEW
Although viewing lists of images in Thumbnail View allows you to see many images at a glance, the amount
of information about the item that can be displayed along with the thumbnails is limited. To see more infor-
mation “at a glance,” try Text List View. You can change easily from Thumbnail View to Text List View by
typing CMD+L, and toggle back to Thumbnail View with CMD+T. You can also change views by selecting
them from the View menu.

In Text List View, double-click the:
• Item name (on the item list) to display the item Info window.
• Thumbnail image to display the item Preview window.
• Word “Keywords” below the Keywords list box to display the Edit Keywords window, where you can

view, add, or delete keywords.
• Description box to display the item Description window, where you can view, add to, or delete descrip-

tion information.

You can also scroll up and down in any of the windows displayed in Gallery Text List View, and resize the
Gallery window as needed.
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USING THE PASTEBOARD
Use the Pasteboard as a temporary storage place for items that you want to work with. For example, you might
need to perform several types of searches to locate all the images you’re interested in. After each search, locate
the items you want and drag them from the Gallery window to the Pasteboard. Return to the Find window and
use different criteria to search for other items, then copy these items to the Pasteboard. New items copied to the
Pasteboard will be added to the items already collected there.

With items on the Fetch Pasteboard you can:
• Export multiple items to another catalog—or create a new catalog for them.
• Preview items from multiple searches at one time, to more easily identify the one you want.
• Copy the original files of each item in your collection to another storage device, perhaps for sending to an

associate, a service bureau, or an agency.
• Collect all the items you’ll be using during one session so you can copy and paste them to other documents

without interrupting your work to search for the next item.
• Print thumbnails of items from multiple searches.

ADDING ITEMS TO THE PASTEBOARD
To add items to the Pasteboard, perform a search so that the Gallery window is open. Open the Pasteboard win-
dow (CMD+M, or select “Pasteboard” from the View menu) so that at least part of it is visible on your desktop.
Select the items from the Gallery window that you wish to add to the Pasteboard, and drag them into the open
Pasteboard window.

REMOVING ITEMS FROM THE PASTEBOARD
To remove an item from the Pasteboard, open the Pasteboard window, select the item, then select “Clear” from
the Edit menu. Note: Fetch automatically clears the Pasteboard window when you quit Fetch or close the catalog.
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One of the greatest values of a catalog is the ability to search for and see image files without opening the appli-
cation that created them, and be able to instantly copy those images to other documents right from the catalog
list. For example, you might place a photograph modified in Adobe® Photoshop® into a newsletter created in
QuarkXPress, or you might want to place a movie created in QuickTime™ into your presentation created in
Adobe Persuasion®.

Fetch makes the entire process very easy. Once you’ve selected an image, you can place it in another document
by dragging (if the application can accept dragged images), or by the standard copy and paste method. You can
copy images from either view of the Gallery window or from the Pasteboard.

COPYING IMAGES—DRAG AND DROP
Some applications, such as PageMaker 6.5 and ClarisWorks, accept images dragged from other applications.
Others, such as QuarkXPress, normally cannot. However, Extensis is developing plug-ins to make this feature
available in other applications. One such plug-in from Extensis, a QuarkXTension® named “QX–Drag&Drop™”
is provided free of charge with Fetch. This file is placed in the Fetch Extras folder located in the Fetch applica-
tion folder when Fetch is installed. To use this QuarkXTension, launch the installer and follow the instructions;
after installation, the drag and drop feature will be activated the next time you launch QuarkXPress.

To drag and drop an image from a Fetch catalog into a QuarkXPress document, simply open to either Gallery
view (Thumbnail or List Text) or the Pasteboard view (described below), and drag the item into your document.
The necessary picture box will be created and placed inside the document at the location of the cursor. Fetch
automatically passes link information to QuarkXPress about the resource file location (refer to QuarkXPress
documentation for more information about linked files). 

COPYING IMAGES—COPY AND PASTE
To copy a cataloged item for pasting in another document, select the item then select “Copy” from the Edit
menu, or press CMD+C. The item will be copied to the standard Clipboard. Note: If the item to be copied is very
large and your RAM memory is limited, you may not be able to copy the item to the clipboard.

To paste the item in a document, select “Paste” from the Edit menu, or press CMD+V.
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Ty p i c a l l y, the majority of images in a catalog will be still images like the T I F F image of grapes illustrated ear-
l i e r. Still images might also be EPS, JPEG, PICT, and many others. However, Fetch offers the ability to catalog
many other types of images, such as sounds, movies, documents, and 3D images. This section offers a simple
overview of other image types. Refer to your Extensis Fetch User Manual for more detailed information.

SOUNDS
Open the Preview window for the sound, and use the playbar to control sound playback. You can start and stop,
rewind, loop, increase or decrease volume, etc.

QUICKTIME™ MOVIES
Open the Preview window for the movie, and use the playbar to control movie playback. You can start and stop,
rewind, loop, increase or decrease volume (if the movie has sound), etc.

KODAK® PHOTOCD IMAGES
Open the Preview window for the image, and use the PCDI pull-down menu to manipulate the image. You can
change resolution of the image in the display, rotate it, flip it, etc.

QUICKDRAW™ 3D IMAGES
Open the Preview window for the image, and use the menu bar at the bottom of the screen to manipulate the
image. You can change the view, move the image  around in the window, resize it, rotate it, etc. Note: 3D images
can only be viewed and manipulated on a Power Macintosh® with QuickDraw 3D enabled.
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CREATING A NEW CATALOG
When creating a catalog, first decide what items you’d like to have in your catalog. You can include documents,
pieces of art, photographs, sound files, movies, multi-media files, folders with items and/or other folders in
them—almost any electronic file can be cataloged! Just be aware that everything inside the folders will become a
catalog item. While you can catalog anything almost instantly, to make the best use of a catalog, we suggest that
you do a little planning before you start. 

The easiest way to create a new catalog is to drag items onto the Fetch application icon. When your release the
items over the Fetch icon, Fetch launches itself and displays a dialog box allowing you to name the new catalog
and indicate where it is to be saved. After you name your catalog, Fetch displays the “Add/Update Options”
window. This screen gives you an opportunity to change many of the default catalog options, giving you enor-
mous control over your catalog entries. You can read more about these many options in your Extensis Fetch
User Manual. For now, simply click “Continue.” Fetch will show a series of windows as it adds the items to the
catalog. Respond “OK” as required until Fetch has completed creating the catalog.

Notes: Fetch allows you to have only one catalog open at a time. You will have to close all catalog windows for the cur -
rently opened catalog (or select Close from the File menu) before you can open another catalog or create a new one.

ADDING ITEMS TO YOUR CATALOG
After you’ve created your catalog, you may find other items you’d like to add to it. You can quickly and easily
add items to your catalog by dragging them  from a folder window and dropping them into the catalog Gallery
window (you can also drag and drop items into the Pasteboard window—refer the section “Using the
Pasteboard” ).When you release your dragged item in a Fetch window, Fetch presents the “Add/Update
Options” window and all of the associated add/update information windows. When the update is complete,
Fetch updates the Gallery (or Pasteboard) window to reflect the new item.

UPDATING ITEMS IN YOUR CATALOG
Remember that Fetch keeps only  a thumbnail of the image in the catalog, and it looks for the actual file when
displaying the Preview window and when placing (copying) images in other documents.  If you move the file
associated with a catalog image, you’ll need to make Fetch aware of the move, and allow it to update the infor-
mation in your catalog. If you do not, Fetch won’t know where to find the image, and you’ll be limited in what
you can do with it—you won’t, for example, be able to copy the image to another document.
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CATALOG INFORMATION
The Catalog Info window provides detailed information about the catalog as a whole, such as the: 

• Number of items in the catalog.
• Creation and modification dates.
• Access and editing privileges.
• List of volumes referenced by the catalog.
• List of all keywords in the catalog.

To open the Catalog Info window, select “Catalog Info” from the File menu, or double-click the upper-left cor-
ner of the information area in either the Gallery or Pasteboard window.

KEYWORDS
Keywords are an important key in your ability to search for and find cataloged items. You can add and delete
keywords for all catalog items in Fetch, and you can extract keywords and descriptions from image source files
when you add them to a catalog. You can add sets of keywords to multiple items at the same time, and you can
delete keywords the same way.

To edit keywords: select “Edit Ke y w o rd s” from the Edit menu. To add one keyword, type in the keyword and click
“Ap p l y.” To add more than one keyword, type in a keyword, then click “Ad d” to add the keyword to the list. En t e r
as many keywords as you wish, clicking Add after each entry. When yo u’ve entered all your keywords, click Ap p l y.

To quickly find all items with a single keyword: display the Gallery window items in Text List View. Locate and
select an item with the keyword you want to search on, then double-click the keyword. Fetch will locate and list
all items with that keyword.

For more information on keywords and keywording strategy, refer to your Extensis Fetch User Manual and to
the “Fetch Keywording Strategies” file in your Fetch application folder.

DESCRIPTIONS
Use the description field to keep track of any information about the item’s source file that you might find useful or
i m p o rtant. You might use the description field to keep notes about the origin of an item, how it might be used,
who created the image, scanner settings, etc. The description for each item can be up to 32,000 characters long.

To edit a description: select the item from either the Gallery or Pasteboard window, then select “Description”
from the Edit menu, or display items in the Text List View of the Gallery window, select the item, then double-
click in the description field for the item.
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LAUNCHING APPLICATIONS FROM FETCH
You can launch the application which created (or can read or edit) a cataloged item directly from Fetch. For
example, you might want to modify photographs using Adobe Photoshop, or make changes to illustrations
using Adobe Illustrator®. Or you might want to view a PDF file in your catalog without leaving Fetch. Fetch
utilizes Macintosh Easy Open™ to determine which application to launch for each type of file in your catalog.
Note: To use this feature, the Macintosh Easy Open extension must be enabled.

To launch an application: Select the item you wish to edit (or view) then choose “Edit Original” from the Item
menu, or use the keyboard shortcut CMD+G, or the shortcut OPTION+double-click the item’s thumbnail.
Fetch will launch the application indicated in the application list in Easy Open, and then open the selected cata-
log item. If no application has been set for this filetype in Easy Open, a dialog box will be displayed so that you
can select an appropriate application. 

SHARING CATALOGS AMONG MULTIPLE USERS
Fetch catalogs can be easily shared across a network with other Fetch 1.5 licensed users. Ap p ropriate security feature s
a re available to ensure that only authorized users can add or delete catalog items, make changes to keywords and
descriptions, etc. For detailed information on setting up shared catalogs refer to your Extensis Fetch User Ma n u a l .

FETCH AND CYBERVIEWER™

Extensis Cy b e r Vi ewe r™, a fre ew a re extension from Extensis Corporation, adds a floating palette to the Ne t s c a p e
Na v i g a t o r™ (v2.0 and above) internet browser which displays each web page you visit as a graphical list, similar
to the thumbnail views in Extensis Fetch. 

The integration of Fetch and CyberViewer provides a sophisticated bookmarking system offering a convenient
way to catalog web pages and quickly navigate the internet. Use CyberViewer thumbnails to create catalogs of
web pages, then use the stored images to launch Netscape and load the selected web page. You can add key-
words and descriptions for each web page, and even share them with your workgroup.

To create a catalog of web pages: From the CyberViewer palette, select the pages you wish to catalog and drag
them to the desktop (or to a folder on any mounted storage device). CyberViewer will create a Netscape URL
file for each page. Next, drag the URL files into the Gallery window of an existing catalog, or drag them over
the Fetch application icon to quickly create a new catalog of your favorite web pages. 

When you’re ready to visit a particular location, select the web page thumbnail in your Fetch catalog, then
choose “Edit Original” from the Item menu (as explained in the section “Launching Applications From Fetch”).
Fetch will launch Netscape and go directly to the selected page.
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LEARNING MORE ABOUT FETCH
We’ve covered a number of Fetch features in this guide, but the information presented was necessarily limited.
There’s much more information available both on the features presented here, and on the many helpful features
and options that we didn’t mention. We invite you to take advantage of the following additional information
sources covering Extensis Fetch:

• Extensis Fetch 1.5 User Manual.
• Fetch Keywording Strategies—an Acrobat PDF file located in your Fetch Extras folder.
• Ballon Help—available from the Finder Help menu bar.
• Fetch Shortcuts—available from the Finder Help menu bar, or by pressing the Help key on your keyboard.
• ReadMe—a text file located in your Fetch application folder with late-breaking information.
• Sample Catalog—a catalog of images for you to play and practice with, located in the Fetch folder on the

Extensis CD.

ADDITIONAL FETCH PRODUCTS
For information on creating and publishing CD catalogs using the Extensis Content Publisher’s Toolkit and
Fetch Browser, or for site license information, contact us at 800-796-9798, and ask for Corporate Sales. Or send
E-mail to sales@extensis.com

OTHER TIME-SAVING PRODUCTS FROM EXTENSIS
In addition to Extensis Fetch, Extensis offers an array of application-specific products that extend the capabili-
ties of popular graphics and layout applications. Extending the capabilities of such award-winning programs as
QuarkXPress, Adobe Photoshop, Adobe Illustrator, Adobe PageMaker, and Macromedia FreeHand™ enables
advertising and design professionals, production artists, and desktop publishers, as well as multimedia develop-
ers, graphic, game, and world wide web designers, digital imagers, and photographers to maximize their invest-
ment in their graphics application software.

A bro c h u re (in Adobe Ac ro b a t® PDF format) for each Extensis product is available for viewing in the Sa m p l e
Catalog, located in the Fetch folder on the Extensis CD. To locate product bro c h u res use the keyword “Extensis.” 

To view an Extensis product brochure: Select the brochure you wish to view, then choose “Edit Original” from
the Item menu, or use the keyboard shortcut CMD+G, or the shortcut OPTION+double-click the item’s
thumbnail. Fetch will launch Adobe Acrobat and open the brochure. Note: You must have the Macintosh Easy
Open extension enabled to use this feature. If Acrobat has not been previously set in Easy Open, a dialog box will be
displayed so that you can locate and select your copy of the Adobe Acrobat Reader.

EXTENSIS CORPORATION
55 S.W. Yamhill Street, Fourth Floor
Portland, OR 97204
Phone: 503-274-2020
Fax: 503-274-0530
E-mail: info@extensis.com
Internet: http://www.extensis.com

CUSTOMER SERVICE
Phone: 800-796-9798
E-mail: sales@extensis.com

TECHNICAL SUPPORT
Phone: 503-274-7030

Monday–Friday, 8am–5pm Pacific
E-mail: support@extensis.com
AOL: Extensis
CIS: 70242,33
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